Question: Physics updates is not updating correctly

When i enter  Physics:-Version() I see the output

The "Physics Updates" version "859" is installed but is not active. The active version of Physics is within the library

   C:\Program Files\Maple 2020\lib\maple.mla, created 2020,  March 4, 20:36 hours


I tried to install it using Maple Cloud. The installation is stuck as seen below. Also i deleted the text file in the toolbox 2020 folder, maybe in the hope of starting from scratch.

Can someone please explain what to do to manually add the physics update, step by step. I am not that computer savvy as some of the users appear in other posts , I did try reading some.
I tried to download the physics update manually but I keep ending up with the same maple worksheet that says you need to use maplecloud.

In case you cannot read the text in the image

Fetching package "Physics Updates" from MapleCloud...
ID: 5137472255164416
Version: 859
URL: File size is 13377536 bytes(12 MB).

Installing package...
PackageTools:-Install("C:/Users/----/AppData/Local/Temp/cloudDownload2413972360095626606/Physics+Updates.maple",overwrite=true,pkgname="Physics Updates"); "

Please Wait...