Question: trouble with solving system of equations, substituting values for some of the variables

Hello, I'm new to Maple, transitioning over from Mathematica.  I have a system of equations I'm trying to solve, but am trying to substitute values for some of the variables.  I don't think I'm doing it right, because I don't see the value in place of the variable when it echos the expression. Here are my equations, and how I'm trying to solve them:

wres := sqrt(C1+C2)/sqrt)C1*C2*L1)

vores := -C1/C2*vin

z3 = (C1^2 *R1- j*sqrt(C1*C2*L1*(C1+C2)))/C2^2

sys :={wres=13.56e6*2*pi, C1=C2, z3=40,abs(vores/vin)>=1}

solve(sys, {C1, C2, L1, R1})


(I apologize; I coulnd't figure out how to enter the Maple code here, directly).


When I try this, solve returns nothing.  I then try forcing R1 to be 2000, for ex.  I tried modifying sys to be


sys:={wres=13.56e6*2*pi, C1=C2, R1=2000,  z3=40,abs(vores/vin)>=1}, but this does't work.

then I tried, R1:=2000, exepcting to see R1 substituted with 2000 in the echo from sys, but it stills shows R1....


How do I do this?  

Also, how do I go about investigating why solve is having trouble solving a system of equations?



Please Wait...