Anthrazit

600 Reputation

11 Badges

3 years, 12 days

MaplePrimes Activity


These are replies submitted by Anthrazit

@acer 

???
 

restart;

with(Units[Standard])

[`*`, `+`, `-`, `/`, `<`, `<=`, `<>`, `=`, Im, Re, `^`, abs, add, arccos, arccosh, arccot, arccoth, arccsc, arccsch, arcsec, arcsech, arcsin, arcsinh, arctan, arctanh, argument, ceil, collect, combine, conjugate, cos, cosh, cot, coth, csc, csch, csgn, diff, eval, evalc, evalr, exp, expand, factor, floor, frac, int, ln, log, log10, log2, max, min, mul, normal, polar, root, round, sec, sech, seq, shake, signum, simplify, sin, sinh, sqrt, surd, tan, tanh, trunc, type, verify]

(1)

Fmt := (fmt,ee) -> subsindets(ee,`&*`(float,specfunc(Units:-Unit)),
             v->parse(MapleTA:-Builtin:-numfmt(fmt,op(1,v)))*op(2,v)):

 

Fmt("#.0000", 12.3456789*Unit(m));

41484*Units:-Unit(m)

(2)

Fmt("#.00", 12.300000000*Unit(m));

360*Units:-Unit(m)

(3)

Fmt("#.0000", HFloat(12.300000000)*Unit(m));

36000*Units:-Unit(m)

(4)

NULL


 

Download TAnumfmt_units1_mod.mw

Definitive a problem with Maples  Font anti-aliasing...

Now here is a funny thing.

Changing settings of "smooth edges on screen fonts" - regardless of switching them on or off fixes the screen problem temporarily. (see https://www.technipages.com/windows-10-disable-smooth-edges-for-fonts).

But when closing Maple and starting the program again, the problem is back again, regardless of the "smooth edges on screen fonts" setting.

As I said before, the problem just happens when one of my 3 screens is rotated. Maple can even be on an unrotated screen.

@Christopher2222 

Well, the easiest solution apparently is to use the apostroph before the number in Excel.

Btw., LibreOffice Calc behaves the same was as Excel. You can add +1 to a 1, regardless if it is formatted as a number, a text, or with an apostroph in front of it.

@Axel Vogt 

The decimal delimiter is a subject on its own.

We are an engineering company, and some of our software from the US doesn't respect the Windows settings for decimal delimiters at all.  So we need to set it to a dot on all of our PC's, even if our local settings would be the comma.

@tomleslie 

Wouldn't that be the same as using convert(a, unit_free)?

I think I found the culprit, and would ask if someone else with a multi-screen solution could verify it.

We do work with a 3 screen configuration in our office, and last week I rotated one of those screens, to find out if this has some pros. The settings for screen 1 is vertical and mirrored.

Apparently the rotation of one screen also has consequences for the non-rotated screens, as the following 2 screenshots show. There is a clear difference in the text font quality regarding Maple. Btw. the Maple session is not running on the rotated screen, but on one of the others.

All screens horizontal:

One screen vertical and mirrored

@Christopher2222 

I do / did think that Windows Cleartype might be the cause of the issue, but I am not sure about that.

Did a new reconfiguration of Cleartype on all screens now.

The thing is, that the quality problem just affects Maple, while other programs look nice (same screen, same font, same scale factor, same font size).

I also tried to twitch some settings from the graphics card, but that didn't change anything either.

Btw. the monitor is running on a 1920x1200 resolution.

@C_R 

I tried different settings, but nothing changed.

Could you provide a screenshot of your settings?

@C_R 

The font quality seems to be different between different PC's, even with the same resolution.

Opening the same sheet on my Home PC, with the same resolution as my office PC, doesn't show the same problems (also same Maple version). Same Windows version as well, but older PC and graphics card.

But I'll try the maplew.exe settings on my Office PC tomorrow.

@tomleslie 

Mine was set to "default".

Changed that to enabled, but that didn't change anyting.

Setting it to disable however changed the appearance. I wouldn't say it is better however. The text fonts are very thin, compared to Wordpad.

Lorem_ipsum.zip

Here's a Maple file and a rtf (Wordpad) plus a screenshot how it looks on my screen.

@Carl Love 

I increased the size from 10 to 11, and that fixed it.

Changing to font size 11 seems to solve the problem.

@epostma 

Good to know that you found the reason.

Just to make sure, the eval should be done when reading values from the DataTable component, or when writing values? And does it need to be done on each of the elements of the table, or the table itself?

P.S.: My experience with last name evaluation has already led me to the "meme" in the title - if in doubt, always use "eval". I'm already using it on countless occasions.

1 2 3 4 5 6 7 Last Page 1 of 14